Re: [ecasound] ecasound-2.8.1+dev-20120527: Engine starts by itself

From: Joel Roth <joelz@email-addr-hidden>
Date: Wed May 30 2012 - 09:45:49 EEST

On Wed, May 30, 2012 at 07:55:30AM +0300, Kai Vehmanen wrote:
> Hi,
> On Mon, 28 May 2012, Joel Roth wrote:
> > I haven't checked this against an old ecasound, but with
> > Nama, we've recently noticed the transport starting by
> > itself, without our issuing a start command.
> thanks. The log looks fairly normal in that after engine-launch the
> transport may automatically start if JACK transport state is rolling when
> starting.
> But I guess in your case, JACK transport is not rolling at this point?

It's just the usual stream of commands to setup the engine, with no start
command issued. I have no other JACK clients running, and
I've set -G:jack,nama,send .

It shows up reliably in the RC code, and reliably *doesn't*
show up in the 2.8.1.

> While digging in to other reports, I found at least one corner case in the
> conditional stop-start logic that is used to handle cop/ctrl additions
> while enigne is running. I think it may restart transport although it was
> stopped before the edit -> a bug.

That's possible. After loading the chain setup, Nama adds
all of the chain operators, so there is a burst
of cop/ctrl additions.

If reason falters (or laziness prevails), I suppose with git
bisect and a little patience it should be possible to track

Joel Roth
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and 
threat landscape has changed and how IT managers can respond. Discussions 
will include endpoint security, mobile security and the latest in malware 
Ecasound-list mailing list
Received on Wed May 30 12:15:01 2012

This archive was generated by hypermail 2.1.8 : Wed May 30 2012 - 12:15:02 EEST