Re: [ecasound] preset-register segfaults ecasound

From: S. Massy <lists@email-addr-hidden>
Date: Mon May 07 2012 - 23:09:35 EEST

On Tue, May 01, 2012 at 06:47:37PM -0400, S. Massy wrote:
> Hello,
>
> Updating from commit 40c1c08f140f0eeee92ae79314688645664995fd to HEAD, I
> nnow get a segfault when calling preset-register. The segfault seems to
> be ladspa related, because it doesn't occur unless LADSPA_PATH is
> defined. Also, a cursory backtrace in gdb shows:
> #1 0x00007fffed8f206c in ?? () from /usr/lib/ladspa//ladspa_guitarix.so
> #2 0x00007fffed86450a in ladspa_descriptor ()
> from /usr/lib/ladspa//ladspa_guitarix.so
Actually, this was bad circumstantial evidence. Deleting
ladspa_guitarix.so actually solves the problem, although I'm not quite
clear as to why preset-register would cause ecasound to segfault while
ladspa-register would not.

Cheers,
S.M.

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
Ecasound-list mailing list
Ecasound-list@email-addr-hidden
https://lists.sourceforge.net/lists/listinfo/ecasound-list
Received on Tue May 8 00:15:02 2012

This archive was generated by hypermail 2.1.8 : Tue May 08 2012 - 00:15:02 EEST