Re: [ecasound] -kog, -kf and LV2 testing needed

From: Kai Vehmanen <kvehmanen@email-addr-hidden>
Date: Sun Apr 29 2012 - 09:10:32 EEST


On Sun, 29 Apr 2012, S. Massy wrote:
> Still have 0.5.0 here: git used to compile fine (with the slight fix)
> but now I get
> audiofx_lv2.h:11:27: fatal error: lilv/lilvmm.hpp: No such file ordirectory

this is on purpose. If you have 0.5.0, or and older version, LV2 will be
by default disabled as the build would fail unless one has manually
modified lilvmm.hpp (as you have). I don't want builds to fail for people
who just have a old version of liblilv in their system, and who are not
necessarily even interested in lV2 support.

But as this impacts most current users of LV2, you can pass
"--enable-liblilv" and LV2 support is enabled despite the version check.

Hopefully this is a workable compromise.

Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
Ecasound-list mailing list
Received on Sun Apr 29 12:15:01 2012

This archive was generated by hypermail 2.1.8 : Sun Apr 29 2012 - 12:15:01 EEST