Re: [ecasound] deprecating C pyecasound impl

From: Kai Vehmanen <kvehmanen@email-addr-hidden>
Date: Sun Apr 15 2012 - 00:25:53 EEST


On Sat, 14 Apr 2012, Alessandro Ghedini wrote:

> Yes, the pure-Python implementation has been the only one installed since
> ecasound 2.3.0 AFAICT (way before I became the ecasound maintainer) and I
> disabled the cext build in 2.8.0 since it was not used anyway.

ok, so that old already. That's very good news (in terms of how tested the
code is), thanks.

I did now notice some issues with the Python implementation as well
( It's at least using "popen2" still, which was deprecated
in python 2.7, so time to update that a bit at least.

"submodule" was in python-2.4. I guess it's reasonable to require
python-2.4+ in 2012, right?

> P.S. I'm subscribed to this list, no need to CC me :)

That's what I thought as well, but just cc'ed to make sure I got your
attention. :)

For Developers, A Lot Can Happen In A Second.
Boundary is the first to Know...and Tell You.
Monitor Your Applications in Ultra-Fine Resolution. Try it FREE!
Ecasound-list mailing list
Received on Sun Apr 15 04:15:03 2012

This archive was generated by hypermail 2.1.8 : Sun Apr 15 2012 - 04:15:03 EEST