Re: [ecasound] Ecasound build process stuck after tests

From: Kai Vehmanen <kvehmanen@email-addr-hidden>
Date: Fri Apr 01 2011 - 23:40:23 EEST


On Fri, 1 Apr 2011, Alessandro Ghedini wrote:

>> ok, this is really interesting. Could you send me the config.h file
>> from a machine where ecasound hangs here (maybe in a private mail
> Sent.

Ok, this looks ok, so e.g. the standard pthread interfaces are correctly
detected, available and in use.

>> Hmm, I have one idea what could happen (and a fix), but it'll take a
>> few days before I have time to put together a patch for testing.
> No hurry.

Ok, here's a snapshot with some changes:

Let me know if this solves the problem and I'll clean up the changes and
make a proper git commit. So far I've not been able to reproduce this
myself, so testing help is much appreciated.

Basicly this snapshot adds a new synchronization point guaranteeing
watchdog thread starts to run before anything else happens. This is
actually a case that was supposed to be handled already in current
codebase, but perhaps that mechanism has a bug...

PS Can you reproduce this only with stresstest.rb or perhaps
    just by running "ecasound --version"...?

Create and publish websites with WebMatrix
Use the most popular FREE web apps or write code yourself;
WebMatrix provides all the features you need to develop and
publish your website.
Ecasound-list mailing list
Received on Sat Apr 2 00:15:04 2011

This archive was generated by hypermail 2.1.8 : Sat Apr 02 2011 - 00:15:04 EEST