Re: [ecasound] ecasound 2.7.2 binary missing from bin directory [SOLVED]

From: Kai Vehmanen <kvehmanen@email-addr-hidden>
Date: Thu Mar 31 2011 - 00:16:58 EEST


On Tue, 21 Dec 2010, linux media 4 wrote:
>> This is the listing of /usr/local/ecasound/bin
>> ecaconvert_debug
>> ecafixdc_debug
>> ecalength_debug
>> ecasound_debug
> I omitted '--enable-debug' from the above configure command and ecasound
> built correctly.

this actually happens on purpose and has been this way since the dawn of
time. This is documented in INSTALL:

         Disables optimizations and other things preventing
         efficient debugging. Created executables and libraries
         have a "_debug" suffix. Disabled by default.

... but I'm first to admit that chances are high that this will surprise
most people. First, nobody reads INSTALL files (as it's really generic in
most packages), and second, '--enable-debug' is a common configure switch,
but nobody else does the whacky "_debug" suffix as a side-effect.

But as getting rid of it is such as a hassle (mostly for me, probably the
only user depending on the "_debug" suffix ;)), I'm not planning to change
this any time soon... unless someone complains loudly enough. ;)

Create and publish websites with WebMatrix
Use the most popular FREE web apps or write code yourself;
WebMatrix provides all the features you need to develop and
publish your website.
Ecasound-list mailing list
Received on Thu Mar 31 04:15:02 2011

This archive was generated by hypermail 2.1.8 : Thu Mar 31 2011 - 04:15:02 EEST