Re: [ecasound] state of pyeca .. r ppl using instead?

From: Kai Vehmanen <kvehmanen@email-addr-hidden>
Date: Sat Sep 04 2010 - 14:03:32 EEST


On Sat, 6 Mar 2010, '2+ wrote:

> import pyeca
> gives me
> /var/lib/python-support/python2.6/
> DeprecationWarning: The popen2 module is deprecated.

this is indeed an issue that needs to get fixed (and patches are very much
welcome as my ancient systems still stick with python2.5)

For now popen2 seems to be still availble (see, so it's still working, but
sooner or later it's going to go away.

The downside is that once we move to 'subprocess' API, ecasound will start
requiring a newer Python ('subprocess' was added to python2.4, which I
think starts to be a fairly reasonable requirement nowadays).

PS One alternative (see my previous mail to ecasound-list) is
    to use the native Ecasound python API -> --enable-pyecasound=c .. this
    links directly against Python so 'subprocess' nor 'popen2' are
    not needed at all, plus it's a bit faster.

This Dev2Dev email is sponsored by:

Show off your parallel programming skills.
Enter the Intel(R) Threading Challenge 2010.
Ecasound-list mailing list
Received on Sat Sep 4 16:15:05 2010

This archive was generated by hypermail 2.1.8 : Sat Sep 04 2010 - 16:15:05 EEST