Re: [ecasound] Chainsetup saving bug

From: Kai Vehmanen <kvehmanen@email-addr-hidden>
Date: Thu Aug 19 2010 - 00:03:59 EEST


On Wed, 18 Aug 2010, Julien Claassen wrote:

> Ecasound ('h' for help)> cs-save-as rp.ecs
> When I edited the file, I found that several inputs were incomplete. I used
> playat for almost anything, and sometimes stacked select on top of that. I

oh yes, there's indeed bugs with saving chainsetups with stacked (e.g.
"playat,123,select,123,112" and so forth) audio objects.

The bug triggers a bit differently if you have connected the chainsetup at
least once (i.e. "audioloop" stacking works in this case), and if you try
to save without first connecting (all stacking info is lost).

Thanks very much for reporting! Bugfix committed to the public git
tree as:

commit 690014d537fa22d4feebb917d30a2adba9d37f70
Author: Kai Vehmanen <kvehmanen -at- eca -dot- cx>
Date: Wed Aug 18 23:54:32 2010 +0300

     Fix bug in saving chainsetups with stacked audio objects

     When saving (e.g. with "cs-save-as" or "cs-edit") a chainsetup
     containing stacked audio objects ("audioloop", "select" or "playat"),
     the stacked audio objects were incorrectly saved, with only details
     from the first object type saved.

     Bug reported by Julien Claassen on ecasound-list on 18 Aug 2010.

This is severe enough that I'll start wrapping up 2.7.2 for release.

This email is sponsored by

Make an app they can't live without
Enter the BlackBerry Developer Challenge
Ecasound-list mailing list
Received on Thu Aug 19 00:15:02 2010

This archive was generated by hypermail 2.1.8 : Thu Aug 19 2010 - 00:15:02 EEST