Re: [ecasound] Chainsetup saving bug

From: Philipp Überbacher <hollunder@email-addr-hidden>
Date: Wed Aug 18 2010 - 12:48:13 EEST

Excerpts from Julien Claassen's message of 2010-08-18 07:19:54 +0200:
> Good morning Everyone!
> Yesterday I worked with a big chainsetup. First I just extended the
> commandline. But then it got so long (32 chains with loads of -ea and -klg and
> a few more), that I wanted to save it. So I used -c for the interactive mode
> and did this:
> Ecasound ('h' for help)> cs-save-as rp.ecs
> When I edited the file, I found that several inputs were incomplete. I used
> playat for almost anything, and sometimes stacked select on top of that. I
> think lines were only cut of in cases of playat,select stacks. They would look
> like this:
> -a:32 -f:s16_le,2,48000 -i:playat,88.4,select,24.0
> It happened quite consistently. Also at some points there was a comma at the
> end of the line, yet mostly not (only two commata and I could see nothing
> special about these chains).
> I'm using Ecasound v2.7.0, self compiled with enable-experimental.
> Kai, do you know, why that might happen? Anyone else ever come across it?
> I maybe out of touch a little for the next week, so I haven't lost
> interest, even if I don't reply directly.
> Kindly yours
> Julien

Hi Julien,
I haven't played with the audiofile sequencing part yet, but I wonder
whether the syntax is correct. It looks like some parameters could be
missing. In the case of select, the duration I guess.


"Wir stehen selbst enttäuscht und sehn betroffen / Den Vorhang zu
und alle Fragen offen." Bertolt Brecht, Der gute Mensch von Sezuan
This email is sponsored by 
Make an app they can't live without
Enter the BlackBerry Developer Challenge 
Ecasound-list mailing list
Received on Wed Aug 18 16:15:01 2010

This archive was generated by hypermail 2.1.8 : Wed Aug 18 2010 - 16:15:01 EEST