Re: [ecasound] 2.7.1 hang when calling 'ecasound [ -h | --help ]'

From: Joel Roth <joelz@email-addr-hidden>
Date: Tue Jul 13 2010 - 10:36:57 EEST

On Sun, Jul 11, 2010 at 01:04:29PM +0200, Philipp ??berbacher wrote:
> > > > It seems like ecasound doesn't quit properly after printing the help
> > > > page, so no matter whether I call it without arguments, with -h or
> > > > --help, it gets stuck and needs a SIGKILL.

> I got another Arch user to test, and it works for him. He's on using a
> 32bit system, so it seems like it's 64bit related in some way.

My unsolicited opinion:

>From my point of view 64bit userland is still "bleeding edge".

I've heard some advocate that 64bit is firmly established,
stable and well-understood technology.

My own experience (with Debian's "sid" distribution for amd64)
was that for every bug that I encountered, I first needed to
answer the question, "does this bug occur in a 32bit

I found the way to answer this question was to maintain
a 32-bit distribution, and then to repeat whatever test
under 32bit conditions.

Now, having gone to all that work, and found several bugs
that are specific to 64-bit applications, I am once again in
a bind. Generally lacking sufficient knowledge (and/or cojones) to
attempt a fix myself, I am left begging for help. Whereas
with 32-bit versions, maintainers have many more users,
creating a stronger incentive to debug in an area
they have more experience, so fixes are often quicker to land.

It took me only a few months to switch back to 32-bit
userland. I guess there can be convincing arguments
for 64-bit, but I'll wait safely behind the curve. :-)


> --
> Regards,
> Philipp

Joel Roth
This email is sponsored by Sprint
What will you do first with EVO, the first 4G phone?
Visit --
Ecasound-list mailing list
Received on Tue Jul 13 12:15:01 2010

This archive was generated by hypermail 2.1.8 : Tue Jul 13 2010 - 12:15:01 EEST