Re: [ecasound] ecasound on OSX 10.5, Error! Cannot make connection

From: Peiman Khosravi <peimankhosravi@email-addr-hidden>
Date: Sat May 22 2010 - 18:27:18 EEST

OK I've been trying further. I run with this command: 'ecasound -ddd
ssshs_cl-N3.wav -o:jack'

and this is what I get at the end of the log:

(audioio_jack_manager) register object jack
(audioio_jack) setting manager to jack
(eca-chainsetup) Registered audio i/o manager "jack" as the current
engine driver.
(eca-chainsetup) Assigning file to chains: default
(eca-chainsetup) Chainsetup "untitled-chainsetup"
(eca-session) NOTE: Unable to create a valid chainsetup from the
command-line arguments.
(eca-control) ECA_CONTROL constructor
(eca-chainsetup) Unable to connect: No inputs in the current
chainsetup. (1.1-NO-INPUTS)
Warning: type DBC_NEVER_REACHED soft-assert '(null)' failed at
  -> eca-control-main.cpp:63 [(null)]
(eca-control) ECA_CONTROL destructor
(eca-session) ECA_SESSION destructor-in
(eca-chainsetup) ECA_CHAINSETUP destructor-in
(eca-chainsetup) Deleting chain "default".
(eca-chain) CHAIN destructor!
(eca-chainsetup) Deleting audio object "jack".
(eca-chainsetup) Deleting audio manager "jack".
(audioio_jack_manager) destructor
(audioio-db-server) destructor
(audioio-db-server) destructor-out
(eca-chainsetup) ECA_CHAINSETUP destructor-out
(eca-session) ECA_SESSION destructor-out

On 22 May 2010, at 12:43, Peiman Khosravi wrote:

> Dear all,
> I am new to ecasound and this list. I have just built and installed
> ecasound on OSX, seemingly successfully. I can call ecasound in the
> terminal with no problems.
> However, my problem is that I cannot get any sound out of it! I
> think it's a problem with the sound device, since the examples are
> for linux and ALSA they do not seem to be working on OSX. I have
> tried ecasound -i somefile.mp3 -o alsa which as you can expect gives
> an error. And ecasound somefile.wav which gives me this error (note
> that I have already launched Jack OSX):
> peiman-khosravis-macbook-pro:~ peimankh$ ecasound -i TapeGrains.wav
> ********************************************************************************
> * ecasound v2.7.1 (C) 1997-2009 Kai Vehmanen and others
> ********************************************************************************
> (libkvutils) kvu_rtcaps: warning! sched_getparam() not supported
> jack_client_new: deprecated
> (eca-chainsetup) Chainsetup "untitled-chainsetup"
> jack_client_new: deprecated
> (eca-chainsetup) NOTE: Real-time configuration, but insufficient
> privileges to utilize real-time scheduling (SCHED_FIFO). With small
> buffersizes, this may cause audible glitches during processing.
> (eca-chainsetup) "rt" buffering mode selected.
> (eca-chainsetup) NOTE: using existing audio parameters -f:s24_le,
> 2,96000 for object 'TapeGrains.wav (tried to open with -f:s16_le,
> 2,44100).
> (eca-chainsetup) Opened input "TapeGrains.wav", mode "read". Format:
> s24_le, channels 2, srate 96000, interleaved (locked params).
> jack_client_new: deprecated
> (eca-chainsetup) NOTE: using existing audio parameters -f:f32_le,
> 2,96000 for object 'jack_alsa (tried to open with -f:s16_le,2,96000).
> (eca-chainsetup) Opened output "jack_alsa", mode "write". Format:
> f32_le, channels 2, srate 96000, noninterleaved (locked params).
> [* Connected chainsetup: "untitled-chainsetup" *]
> [* Controller/Starting batch processing *]
> [* Engine - Driver start *]
> (audioio_jack_manager) Error! Cannot make connection ecasound:out_1 -
> > alsa_pcm:playback_1.
> (audioio_jack_manager) Error! Cannot make connection ecasound:out_2 -
> > alsa_pcm:playback_2.
> [* Engine - Processing finished *]
> [* Controller/Batch processing finished (0) *]
> [* Engine exiting *]
> (eca-control-objects) Disconnecting chainsetup: "untitled-
> chainsetup".
> I would really appreciate your comments as I am eager to try
> ecasound in my search for a non GUI DAW.
> Thanks in advance
> Peiman


Ecasound-list mailing list
Received on Sat May 22 20:15:02 2010

This archive was generated by hypermail 2.1.8 : Sat May 22 2010 - 20:15:02 EEST