Re: [ecasound] Problem with 2.7.0

From: Pierre Lorenzon <>
Date: Tue Oct 20 2009 - 08:11:34 EEST


Thanks first for having fixed this problem and for this precise
and convincing explanation !



From: Kai Vehmanen <kvehmanen@email-addr-hidden>
Subject: Re: [ecasound] Problem with 2.7.0
Date: Tue, 20 Oct 2009 00:47:11 +0300 (EEST)

> Hi,
> On Mon, 19 Oct 2009, Pierre Lorenzon wrote:
>>> hmm, ok, I have one hypothesis. Here's one snapshot, let me
>>> know if it helps:
>> Yes it does ! The problem no longer exists with this version.
> ok, great, that is really good news. I now wrote a longer mail
> about this to ALSA list:
> The good news is that this bug should not hit too many
> people. Most ALSA PCMs support power-of-two period-sizes
> (-b:1024, -b:128, ...), and in these cases no glitches should
> not occur.
> In your specific case, I think the PCM doesn't support -b:1024
> but something close, as the block/period size. Now due to the
> bug this results in discontinuity at every block, leading to
> glitches at a rate of ~20Hz when playing 44.1kHz audio. This
> matches pretty closely what you described.
>>> Also, I'd be interested to know which version of alsa-lib
>> 1.0.13
>>> (libasound) do you have, and which kernel version?
> These match as well. These still have the old implementation of
> snd_pcm_sw_params_set_xfer_align both in alsa-lib and in
> kernel.
> Thanks for helping to track this down! I'll release 2.7.1
> soonish with this fix (and possibly a few others as well)
> included.

Come build with us! The BlackBerry(R) Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9 - 12, 2009. Register now!
Ecasound-list mailing list
Received on Tue Oct 20 12:15:01 2009

This archive was generated by hypermail 2.1.8 : Tue Oct 20 2009 - 12:15:01 EEST