Re: [ecasound] streaming with ecasound

From: Simon Eigeldinger <simon.eigeldinger@email-addr-hidden>
Date: Fri Oct 02 2009 - 01:19:38 EEST

Hi Kai,

On 2 Oct 2009 at 0:28, Kai Vehmanen wrote:

> Hi,
> > But when i want to pipe it to lame and then into a streaming program
> > like that i get white noise:
> like Sergei noted, you need to make sure all apps use the same audio
> format: sample format (int/float, signed/unsigned, bits, endianess, etc),
> channels, sampling rate.
> > ecasound -i alsa -o stdout | lame -b 64 - - | ezstream -c config.xml
> So that would be (with lame 3.98 and newer) for instance something
> like:
> ecasound -f:s16_le,2,44100 -i alsa -o stdout | lame -b 64 -r -S
> --signed --bitwidth 16 --little-endian -s 44.1 - - | ezstream ...

Thanks Kai. it worked. had to add -x to lame and had to specify the

I used as streaming recorder arecord before but this terminated after
4-6 hours of use. let's hope we can go better with ecasound. we will
see how that does.

On the linux box i have a older lame (3.97) but i have now something

Thanks all for the fast help.

Greetings from Austria,

Come build with us! The BlackBerry&reg; Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9&#45;12, 2009. Register now&#33;
Ecasound-list mailing list
Received on Fri Oct 2 04:15:02 2009

This archive was generated by hypermail 2.1.8 : Fri Oct 02 2009 - 04:15:02 EEST