Re: [ecasound] problems running lame to convert oggs to mp3s

From: Kai Vehmanen <kvehmanen@email-addr-hidden>
Date: Thu Sep 24 2009 - 09:54:21 EEST


On Tue, 22 Sep 2009, David O'Toole wrote:

> converting all my music to mp3 format. However, I can't seem to do this
> with ecasound like i want... even with lame installed, ecasound can't
> seem to run lame properly. What am I doing wrong? Here's the output with

my guess is that you have lame 3.98 or newer. The command-line options
have changed and that breaks ecasound. This is fixed in git tree with

commit af1035fa99bcb88662f2b15e27fc81f9ff876345
Author: Kai Vehmanen <kvehmanen -at- eca -dot- cx>
Date: Sun Mar 22 00:49:38 2009 +0200

     Fixed mp3 encoding/output with lame 3.98 and newer

     The command-line syntax of 'lame' mp3 encoder, and semantics
     for old options, have changed slightly in lame 3.97 and 3.98.
     This patch updates the default command used to launch lame, and
     also provides some extra code to support old version of lame,
     as well as to support old ecasoundrc files (to avoid problems
     when upgrading Ecasound).

... if you want to use this with 2.6.0, you also need to take patch

PS Yes, 2.7.0 should have been released by now. :( The reason
    for the delay is the possible realtime problem in current
    git (as reported by Julien -> possible system freeze with
    rt-scheduling). I probably have to consider backporting
    some of the changes and release an intermediate 2.6.1.

Come build with us! The BlackBerry&reg; Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9&#45;12, 2009. Register now&#33;
Ecasound-list mailing list
Received on Thu Sep 24 12:15:05 2009

This archive was generated by hypermail 2.1.8 : Thu Sep 24 2009 - 12:15:06 EEST