Re: [ecasound] batch aborts with ladspa plugins

From: Kai Vehmanen <kvehmanen@email-addr-hidden>
Date: Sun May 10 2009 - 22:40:47 EEST


On Wed, 6 May 2009, Art Sulger wrote:

> I have a problem when running ecasound in batch mode and it calls ladspa plugins.
> This worked fine some number of kernels ago, and with the previous ecasound (version 2.5.1?).
> It seems to be the Operating system, not ecasound, because I know also have the error in the
> other version.
> *** glibc detected *** ecasound: double free or corruption (!prev): 0x09026df0 ***
> ======= Backtrace: =========
> /lib/[0x17f3a4]
> /lib/[0x181356]
> /usr/lib/[0x572591]
> /usr/lib/[0x5725ed]
> /usr/lib/ladspa/[0x903529]

I belive this is a bug in LADSPA plugin. See e.g. this
older thread:

This error message is emitted by newer versions of glibc (so the problem
has been there all the time, but older glibc versions didn't warn about

The mail linked above has some suggestions how to get rid of the error.

The NEW KODAK i700 Series Scanners deliver under ANY circumstances! Your
production scanning environment may not be a perfect world - but thanks to
Kodak, there's a perfect scanner to get the job done! With the NEW KODAK i700
Series Scanner you'll get full speed at 300 dpi even with all image
processing features enabled.
Ecasound-list mailing list
Received on Mon May 11 00:15:02 2009

This archive was generated by hypermail 2.1.8 : Mon May 11 2009 - 00:15:02 EEST