[ecasound] ecasound-2.5.2 - strange effect of '-ea:amplify-100 -ev'

From: Sergei Steshenko <sergstesh@email-addr-hidden>
Date: Tue Sep 02 2008 - 20:59:39 EEST

Hello All,

with only '-ev' I'm getting this:

"
(eca-chain) (audiofx) -- Amplitude statistics -----------------------------
Range, pos/neg, count,(%), ch1...n
Pos -1.0 dB: 0,0.000% 0,0.000%
Pos -2.0 dB: 0,0.000% 0,0.000%
Pos -4.0 dB: 0,0.000% 0,0.000%
Pos -8.0 dB: 1087,0.007% 922,0.006%
Pos -16.0 dB: 519477,3.574% 513555,3.533%
Pos -32.0 dB: 4459939,30.683% 4456212,30.658%
Pos -64.0 dB: 2117538,14.568% 2125962,14.626%
Pos -inf.0 dB: 279920,1.926% 279896,1.926%
Neg -inf.0 dB: 157160,1.081% 157782,1.086%
Neg -64.0 dB: 2105513,14.485% 2109435,14.512%
Neg -32.0 dB: 4347049,29.907% 4353365,29.950%
Neg -16.0 dB: 545570,3.753% 536194,3.689%
Neg -8.0 dB: 2107,0.014% 2037,0.014%
Neg -4.0 dB: 0,0.000% 0,0.000%
Neg -2.0 dB: 0,0.000% 0,0.000%
Neg -1.0 dB: 0,0.000% 0,0.000%
(audiofx) Peak amplitude, period: pos=0.53241 neg=0.62145.
(audiofx) Peak amplitude, all : pos=0.53241 neg=0.62145.
(audiofx) Clipped samples, period: pos=0 neg=0.
(audiofx) Clipped samples, all : pos=0 neg=0.
(audiofx) Max gain without clipping, all: 1.60914.
(audiofx) -- End of statistics --------------------------------
"

- so far so good.

When I provide '-ea:amplify-100 -ev' in the same place command line, I'm
getting this:

"
(eca-chain) (audiofx) -- Amplitude statistics -----------------------------
Range, pos/neg, count,(%), ch1...n
Pos -1.0 dB: 0,0.000% 0,0.000%
Pos -2.0 dB: 0,0.000% 0,0.000%
Pos -4.0 dB: 0,0.000% 0,0.000%
Pos -8.0 dB: 0,0.000% 0,0.000%
Pos -16.0 dB: 0,0.000% 0,0.000%
Pos -32.0 dB: 0,0.000% 0,0.000%
Pos -64.0 dB: 0,0.000% 0,0.000%
Pos -inf.0 dB: 14535360,100.000% 14535360,100.000%
Neg -inf.0 dB: 0,0.000% 0,0.000%
Neg -64.0 dB: 0,0.000% 0,0.000%
Neg -32.0 dB: 0,0.000% 0,0.000%
Neg -16.0 dB: 0,0.000% 0,0.000%
Neg -8.0 dB: 0,0.000% 0,0.000%
Neg -4.0 dB: 0,0.000% 0,0.000%
Neg -2.0 dB: 0,0.000% 0,0.000%
Neg -1.0 dB: 0,0.000% 0,0.000%
(audiofx) Peak amplitude, period: pos=0.00000 neg=0.00000.
(audiofx) Peak amplitude, all : pos=0.00000 neg=0.00000.
(audiofx) Clipped samples, period: pos=0 neg=0.
(audiofx) Clipped samples, all : pos=0 neg=0.
(audiofx) Max gain without clipping, all: 1.00000.
(audiofx) -- End of statistics --------------------------------
".

I didn't expect ecasound behavior to change in the second case, since
100% amplification is a no operation.

What am I getting wring here ?

Anyway, the

Pos -inf.0 dB: 14535360,100.000% 14535360,100.000%

line looks like a bug to me.

...

Have just noticed that I can also specify '-ea:amplify-100%', i.e. with
the '%' sign, ecasound accepts it. The end result is the same.

Isn't '%' acceptance a bug ?

Thanks,
  Sergei.

      

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Ecasound-list mailing list
Ecasound-list@email-addr-hidden
https://lists.sourceforge.net/lists/listinfo/ecasound-list
Received on Wed Sep 3 00:15:01 2008

This archive was generated by hypermail 2.1.8 : Wed Sep 03 2008 - 00:15:01 EEST