Re: [ecasound] pyecasound not built

From: Kai Vehmanen <kvehmanen@email-addr-hidden>
Date: Mon Sep 01 2008 - 23:11:01 EEST


On Wed, 27 Aug 2008, Oliver Oli wrote:

> Do you know why pyecasound is not build, when building ecasound.
> configure finds the python libraries and includes. I'm on os x.

could this be the same issues as was reported by one OS X user a few years
ago. He posted a patch as well, but as the patch was ready for merging as
is, it never ended up an upstream release. If you want to try it out, you
can get the patch from the original post at:

So in short, some extra flags (-lpython -bundle) need to be passed to the
linker when building Python modules on OS X. I don't have any OS X
machines myself, so I can't verify whether this patch is really needed or
not (-bundle seems to create Mach bundle objects, but I have no idea what
those are and whether they are strictly required to load the modules to

Currently there are no hooks to pass any platform-specific flags (as
libtool is supposed to take care of this), so adding this to upstream
releases is a bit tricky. But it would be a start to know which flags are

PS One alternative would be to provide a standard python distutils for pyecasound. This might not be a bad idea after all...

This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
Ecasound-list mailing list
Received on Tue Sep 2 00:15:04 2008

This archive was generated by hypermail 2.1.8 : Tue Sep 02 2008 - 00:15:04 EEST