[ecasound] 2.5.0 crashing X

From: Oliver Oli <oliver.oli+0815@email-addr-hidden>
Date: Tue Aug 19 2008 - 01:08:06 EEST

i think i crashed it once with

ecasound dave48.wav -o:alsa,hw:0,0

but the last time it took me like 30 to 50 tries to crash ecasound.

i have attached a logfile from the crashed session

ecasound dave48.wav -i:tap_tremolo,50,50 -o:alsa,hw:0,0 2> eca.crash

On Mon, Aug 18, 2008 at 11:50 PM, Kai Vehmanen <kvehmanen@email-addr-hidden> wrote:
> Hi,
> On Mon, 18 Aug 2008, Oliver Oli wrote:
>> i had some forked ogg123 processes still running in the background.
>> but that crash happens with wav playback, too. i also used a ladspa
>> plugin. i'm not on linux now, but i think it was something like:
>> ecasound -i dave48.wav -eli:1234,5 -o jack_auto (but same with alsa)
> thanks a lot for the quick response -- this helps to nail down the problem.
> I've been trying reproduce this on two different systems (one Debian,
> one Redhat; both 32bit), but so far no luck. I'll continue debugging
> tomorrow...
>> it crashed with some glibc memory error. i have to copy and paste it,
>> the next time i use linux. for me it looks like a bug in ecasound that
> I've traced one glibc-reported memory error to the sine.so LADSPA plugin
> (from LADSPA-SDK package). I'm not sure if it is related, but if it is, then
> the error should only occur when you are using LADSPA plugins (as ecasound
> will load all plugins to fill its internal registry). The problem is
> triggered at cleanup time.
> --

This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world

Ecasound-list mailing list

Received on Tue Aug 19 04:15:03 2008

This archive was generated by hypermail 2.1.8 : Tue Aug 19 2008 - 04:15:03 EEST