Re: [ecasound] Problems getting realtime recording.

From: Andrew Lees <andrewl.oz@email-addr-hidden>
Date: Thu Jul 03 2008 - 10:17:52 EEST

On Tue, 2008-07-01 at 20:20 -0700, Avuton Olrich wrote:

> Running v2.6.25.8-rt7 (and other kernels I have tried) and recording
> with ecasound I'm getting messages like:

I have had serious problems, including recording failures and kernel
oops/lockups with alsa and kernel 2.6.25, such that I've reverted to
2.6.24 for now. I had neither time nor expertise to track the issues
down, but figured I'd try again in a little while and see if it was more
than a temporary issue. I too got those huge break numbers, but if you
avoid real time (use nice and more buffering), you may find they become
more sensible. Irrespective of scheduling choices, though, the system
was still unstable. Problems of various types occurred with all alsa
input use, not only ecasound, so it was clearly a kernel/driver issue.
I was using the usb driver with a creative external device.

2.6.25-tuxonice-r4 was unstable, 2.6.24-gentoo-r8 works without a hitch,
same alsa library, same user level software, same kernel compile config.

> warning! playback overrun - samples lost! Break was at least
> 1214667212122.58 ms long.
> Could this be a false alarm?
> I have also gotten the following error message (repeated many times):
> Unknown device state '3'
> This one causes recording to stop, for sure.
> Any idea how to track down these issues?
> Thanks!

Sponsored by: Community Choice Awards: VOTE NOW!
Studies have shown that voting for your favorite open source project,
along with a healthy diet, reduces your potential for chronic lameness
and boredom. Vote Now at

Ecasound-list mailing list
Received on Thu Jul 3 12:15:02 2008

This archive was generated by hypermail 2.1.8 : Thu Jul 03 2008 - 12:15:03 EEST