Re: [ecasound] recording from jack

From: Kai Vehmanen <kvehmanen@email-addr-hidden>
Date: Tue Apr 04 2006 - 09:20:22 EEST

On Mon, 3 Apr 2006, Tommi Sakari Uimonen wrote:

> Hi. I tried to record from jack, but I could not figure out how to make the
> connections so that they would exist before transport starts rolling.
> If I start with interactive mode, ecasound does not show up as jack client
> until I start engine and I guess there is no way to make the connections from
> iam before I start rolling. Or is it possible to make the ports before engine
> starts?
> Unfortunately users guide "6.2.3 Use with JACK" still remains in "to be
> written..".

Hmm, that's "Ecasignal with JACK", there's lots of stuff about JACK in the
"7.6 JACK Server" section. See

See especially 7.6.3 which describes how to solve this specific problem
(start ecasound in transport-slave mode, and start with "engine-launch").

> Is it so that ecasound only creates the input ports and does not handle the
> connections? So I have to use other programs to make the actual connections
> between ports?

Ecasound provides different types of JACK audio objects, "jack" and
"jack_generic" do not autoconnect, while "jack_auto" and "jack_alsa" do.
The connections are done when the engine is launched ("start",

  links, my public keys, etc at
This SF.Net email is sponsored by xPML, a groundbreaking scripting language
that extends applications into web and mobile media. Attend the live webcast
and join the prime developer group breaking into this new coding territory!
Ecasound-list mailing list
Received on Tue Apr 4 16:15:02 2006

This archive was generated by hypermail 2.1.8 : Tue Apr 04 2006 - 16:15:02 EEST