Re: [ecasound] Error starting lame.

From: Kai Vehmanen <kvehmanen@email-addr-hidden>
Date: Sat Mar 25 2006 - 18:16:05 EET


On Sat, 25 Mar 2006, Dave Serls wrote:

>> ecasound -i alsa,default -o foo.wav
>> These are equivalent to running arecord without any extra parameters.

and btw the above is also same as:

ecasound -i alsa -o foo.wav

> I've never seen adequate or understandable (by me) documentation for using and defining
> the ALSA plugins. I do have some copied stuff in my .asoundrc -- but it's for the
> the linux audio PC downstairs (shared home directory).

Well, there's some documentation, but I admit the syntax is a bit complex.
But OTOH, normal users should _not_ need to edit ~asoundrc. The 'default'
device is good for most uses and that is the default also ecasound uses.
So unless you have a specific need, just use "ecasound -i alsa -o alsa".

The difference between "-i:alsahw:0" and "-i:alsa,default" is that with
the latter, alsa-lib takes automatically care of various conversions/etc
needed by different types of soundcards. Ecasound can do some of the
conversions itself (that's why "-i:alsahw,0" works in many cases), but of
course, ALSA is really the right component to perform
soundcard/chipset-specific tasks.

  links, my public keys, etc at
This SF.Net email is sponsored by xPML, a groundbreaking scripting language
that extends applications into web and mobile media. Attend the live webcast
and join the prime developer group breaking into this new coding territory!
Ecasound-list mailing list
Received on Sat Mar 25 20:15:03 2006

This archive was generated by hypermail 2.1.8 : Sat Mar 25 2006 - 20:15:03 EET