[ecasound] alsa playing/recording error, delta66

From: lance <lance@email-addr-hidden>
Date: Thu Aug 18 2005 - 16:10:25 EEST

Hello,

I have an AMD64 300+ a Debian i386 system with kernel 2.6.8
I might add that ecasound plays fine if I use
0 [CK8S ]: NFORCE - NVidia CK8S
                     NVidia CK8S at 0xfa002000, irq 11

If I use the Delta66 card:

$cat /proc/asound/cards
0 [M66 ]: ICE1712 - M Audio Delta 66
                     M Audio Delta 66 at 0xa000, irq 161
mplayer works fine but ecasound hangs HARD!

$mplayer file.mp3
MPlayer 1.0pre7-3.3.5 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices (Family: 8, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE SSE2

Playing file.mp3
Audio file detected.
Clip info:
 Title:
 Artist:
 Album:
 Year:
 Comment:
 Genre:
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
mpg123: Can't rewind stream by 64 bits!
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Checking audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
AF_pre: 44100Hz/2ch/s16le
AO: [oss] 44100Hz 2ch s16le (2 bps)
Building audio filter chain for 44100Hz/2ch/s16le -> 44100Hz/2ch/s16le...
Video: no video
Starting playback...
A: 0.8 (00.8) 0.5%

ecasound -i file.wav -o alsa,plughw:0 hangs system
ecasound -i file.wav -o alsa,default hangs system

ecasound -D -i file.mp3 -o alsa,default
******************************************************
     ecasound v2.4.1 (C) 1997-2005 Kai Vehmanen
******************************************************

[* Chainsetup created (cmdline) *]
[* Connecting chainsetup *]
(eca-chainsetup) 'rt' buffering mode selected.
(eca-chainsetup) Audio object "01 - Manolo Caracol - Fandangos.mp3", mode "read".
(audio-io) Format: s16_le, channels 2, srate 44100, interleaved.
(eca-chainsetup) Audio object "alsa", mode "write".
(audio-io) Format: s16_le, channels 2, srate 44100, interleaved.
[* Chainsetup connected *]
(eca-control-objects) Connected chainsetup: "command-line-setup".
[* Controller/Starting batch processing *]
[* Engine init - Driver start *]
(eca-engine) Using realtime-scheduling (SCHED_FIFO).
(eca-engine) Prefilling i/o buffers.

NOTHING HAPPENS

CTL-C
HAVE TO USE KILL -9 PID to kill ecasound

[* Controller/Processing stopped (cond) *]
Warning: DBC_ENSURE failed - "is_running() == false", eca-control-base.cpp, 270.[* Controller/Processing stopped (cond) *]
Warning: DBC_ENSURE failed - "is_running() == false", eca-control-base.cpp, 270.

Lance

-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Ecasound-list mailing list
Ecasound-list@email-addr-hidden
https://lists.sourceforge.net/lists/listinfo/ecasound-list
Received on Fri Aug 19 00:15:07 2005

This archive was generated by hypermail 2.1.8 : Fri Aug 19 2005 - 00:15:07 EEST