Re: [ecasound] Resampling in realtime / resampling quality problem

From: Kamil Wencel <wencel@email-addr-hidden>
Date: Sat Feb 19 2005 - 13:41:55 EET

Kai, Aaron, fellows,

tricky :

ecasound -f:16,2,96000 -i resample-hq,44100,foo.wav -f:24,2,96000 -o alsa

just uses the internal DAC of my ice1712 card. Since I am using an
external 24/96 DAC I needed the signal
routed there. This is why ecasound didn't throw up any errors.
Technically it was working fine, I just wasn't
able to hear what it was doing because I don't even have cables
connected to the ice1712's analog output.
So I didn't give you enough input to understand the "problem"

the trick is :

ecasound -f:16,2,96000 -i resample-hq,44100,foo.wav -f:24,2,96000 -o

which in my case was :

ecasound -f:16,2,96000 -i resample-hq,44100,foo.wav -f:24,2,96000 -o
alsa, spdif96

relating to my .asoundrc :

pcm.ice1712 {
     type hw
     card 0
     device 0

ctl.ice1712 {
     type hw
     card 0

pcm.analogout {
     type plug
     ttable.0.0 1 # (Out Left)
     ttable.0.1 1 # (Out Right)

          slave.pcm ice1712

  pcm.spdif96 {
     type plug
     ttable.0.8 1 # (Out Left, 2)
     ttable.0.9 1 # (Out Right, 2)

           slave.pcm {
                type hw
                 card 0

Kai, Aaron tell me something please :

What is the differnece between these lines ? I am still not really
certain what effects these changes have

ecasound -f:16,2,96000 -i resample-hq,44100,foo.wav -f:24,2,96000 -o
alsa, spdif96
ecasound -f:24,2,96000 -i resample-hq,44100,foo.wav -f:24,2,96000 -o
alsa, spdif96
ecasound -f:32,2,96000 -i resample-hq,44100,foo.wav -f:24,2,96000 -o
alsa, spdif96

                   ^^ Input Sample Rate /bit ??

                                                                                ^^ Output sample Rate / bit
                                                                                    This works with 24 and 32 as well

whatever I change in the first -f: it always comes to this result :

- [ Connecting chainsetup ]
(eca-chainsetup) 'rt' buffering mode selected.
(eca-chainsetup) Audio object "uninitialized", mode "read".
(audio-io) Format: s16_le, channels 2, srate 96000, interleaved.
(eca-chainsetup) Audio object "alsa", mode "write".
(audio-io) Format: s32_le, channels 2, srate 96000, interleaved.

last but not least :

I can also give my go for the resampling issue. I had some time this
morning so I fetched the snapshot from
12.10.2004 and build it from scratch. Aaron's tests with sinewaves were
very good for comparison but I like
to trust my ears. NO hearable distortions whatever. The clearly hearable
noise is gone as well.

I have both ecasound versions installed parallel so I tried them both.
THIS is clearly a BIG improvement. Therefore
I can give my go for 2.4 as I consider this issue solved. Many many
thanks to Kai, Aaaron and everyone else
who contributed time and efforts to this.

Kai Vehmanen wrote:
> On Fri, 18 Feb 2005, Kamil Wencel wrote:
>>ecasound -f:16,2,96000 -i resample-hq,44100,foo.wav -f:24,2,96000 -o alsa
>>ecasound -f:16,2,96000 -i resample-hq,44100,foo.wav -f:24,2,96000 -o alsahw,x,y
> [...]
>>don't seem to work. How would a proper line for 16/44 to 24/96 resample-hq
>>real time conversion look like ?
> It's difficult to say without knowning what's the problem -- ecasound
> reports an error, audio output is bad, ...?
> The commands look perfectly fine. Few things to try:
> - use resample instead of resample-hq to make sure you have
> enough CPU power for the resampler
> - use "-f:32,2,96000" for the output format (most 24bit cards
> use 32bit samples with the low 8 bits zeroed)

SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now.
Ecasound-list mailing list
Received on Mon Feb 21 00:15:09 2005

This archive was generated by hypermail 2.1.8 : Mon Feb 21 2005 - 00:15:10 EET