Re: [ecasound] os x compile failure

New Message Reply About this list Date view Thread view Subject view Author view Other groups

Subject: Re: [ecasound] os x compile failure
From: j.c.w. (
Date: Fri Oct 29 2004 - 18:19:14 EEST


i found success with the following modifications:

first, i changed the references in configure and the Makefile from -lrt
to -lSystem as per a post returned by google found here:

i'm not sure if that's a good idea or not. it compiled without any
more errors in that spot and seems to function (with the adjustment
made in my next note). if this is not advisable, please let me know
and i'll try something else. otherwise, it just works.

second, i did use your --enable-pyecasound=python suggestion and that
fixed the only other problem that i had.

this was all done with the source recommended below. everything now
works swimmingly with jack on os x 10.3! there are debug messages
popping up here and there, but the functionality of the program has not
been affected thus far.

thanks so much for the work that you and the other ecasound
contributors have done. i use ecasound regularly on my workstation at
home and really found life on the powerbook to be lacking without it.
funny that i have this os that is renowned for its gui and all i want
out of life is a simple (yet incredibly powerful) cli sound app. this
fills a gaping hole in my portable studio.

thanks again and happy noise making!

btw, if you need any further os x testing, just give me a shout! i am
more than willing to pitch in as needed.


On Oct 29, 2004, at 1:30 AM, Kai Vehmanen wrote:

> On Thu, 28 Oct 2004, j.c.w. wrote:
>> i just grabbed the 2.4.3 source and tried to fire it up on os x 10.3.
>> it was a no go. i get the following:
> I guess you are talking about 2.3.4...? :)
>> eca-chainsetup.cpp: In member function `void
>> ECA_CHAINSETUP::lock_all_memory()
>> ':
>> eca-chainsetup.cpp:621: error: `::mlockall' undeclared (first use
>> here)
>> eca-chainsetup.cpp:621: error: `MCL_CURRENT' undeclared (first use
>> this
>> function)
> Could you verify whether "-D_P1003_1B_VISIBLE" is used as an gcc option
> during compilation?
> And also, do you have the line '#define HAVE_MLOCKALL 1' in
> ecasound-2.3.4/config.h after running configure?
>> any thoughts? i would love to have ecasound running on my powerbook.
>> hopefully i've just done something silly.
> I'm afraid I'm the silly one here. :) I thought I had finished all the
> OS
> X related changes, but now it seems I've forgotten something out. :(
> You can get around the problem by commenting (put '/* */' around the
> line) out the '#define HAVE_ML...' line in config.h, and then running
> make. But I really should fix this properly so that memory locking is
> not
> just disabled, as it should really work on OS X.
> --
> Audio software for Linux!
> --
> To unsubscribe send message 'unsubscribe' in the body of the
> message to <>.

New Message Reply About this list Date view Thread view Subject view Author view Other groups

This archive was generated by hypermail 2b28 : Fri Oct 29 2004 - 18:17:05 EEST