[ecasound] GRATZ KAI!

New Message Reply About this list Date view Thread view Subject view Author view Other groups

Subject: [ecasound] GRATZ KAI!
From: Jeremy Hall (jhall_AT_uu.net)
Date: Wed Mar 13 2002 - 17:38:09 EET


After changing my -f: (default format) in ~/.ecasound/ecasoundrc from
s16_le,2,44100,i to s16_le,2,48000,i, I tried the ultimate jack test, my
multitrack session. The session consists of 7 tracks with 3 busses, and
two more behind them, for example:

tracks 4, 6, and 17 feed chain 22
tracks 11,12,13,15 and 16 feed chain 23 (so I guess it's 8 tracks)

Tracks 7 and 8 feed chain 25, and chains 22, 23, and 25 feed both chains
26 and 27. 26 feeds jack_alsa,out and 27 feeds a mixdown file, which is
actually a fifo (mkfifo) which transmits off to the network.

Each vocal chain, (4, 6, and 17) have channel copy, pan, simple_rms
compressor, and amplify. Chain 17 also has single_para, noisegate, and an
additional amp (kindda like a preamp)

The instruments, 11,12,13,15,16, have channel copy, pan, and amplify. 7
and 8 have 3 singleband parametrics, pan and I think amplify, maybe

22 has freeverb3 and amplify
23 has amplify
25 has freeverb3 and amplify
26 and 27 have amplify (because of so many channels and ecasound quietens

The frames_per_cycle was set at 256 for network reasons. I had to turn
double buffering on, but since it didn't seem to cause me problems, I left
it that way. Turning double buffering off caused the jack monster to get
me, but not a subgraph timeout, rather ecasound was dumped and in state
running...so that concludes to me that it is not finished when it is
supposed to be.

at any rate, GRATZ KAI! I have not tried recording another track with this
yet. I have also not tried the 64 frames_per_cycle test yet.

I have noticed that sometimes when resetting the file position, the first
track, track #4, can get a few hundred ms out of sync. Instructing the
setpos again fixes this problem.

Changing file positions _ALWAYS_ makes the jack monster get me, but that's
pretty much expected since it has to reload its targets.


To unsubscribe send message 'unsubscribe' in the body of the
message to <ecasound-list-request_AT_wakkanet.fi>.

New Message Reply About this list Date view Thread view Subject view Author view Other groups

This archive was generated by hypermail 2b28 : Wed Mar 13 2002 - 17:26:47 EET