[ecasound] midi

New Message Reply Date view Thread view Subject view Author view Other groups

Subject: [ecasound] midi
From: Anthony (avan@uwm.edu)
Date: Sat May 05 2001 - 07:16:52 EEST

I haven't seen my last message go thru, so sorry if I'm repeating
myself. I got the midi named pipe working. Ecasound was segfaulting
when trying to read midi-data from an empty pipe. If I pre-fill the
pipe before starting ecasound it all works. Is this a bug?

I have also managed to compile and run Xphat (took a few hacks). I
would like to use something like this along with ecasound to do
multitrack mixing and effects proccesing in real time. I'm having a
lot of trouble testing the combination, mainly due to the first
issue. I have, however, had some success.

Has anyone used xphat with eca? Any suggestions/advice? Xphat
seems to be no longer maintained. Does anyone know of something more

Also, how expensive is software midi-emulation like this compared to
having a hardware continuous controller? Is polling the named pipe
for midi data efficient? Eventually, I would like to be able to record
say 4-trks and the use something like xphat + eca to mix / process
these tracks in real time. Can I achieve similar results as a hardware
recorder? Thanks again. Ant.

BTW, 2.0 compiled without any problems. (Except: I don't use arts and
have to add --disable-arts on the configure. Note, that this does not
show up as an option to configure --help, I just guessed. It might be
a good idea to add this to the help output.)

To unsubscribe send message 'unsubscribe' in the body of the
message to <ecasound-list-request@wakkanet.fi>.

New Message Reply Date view Thread view Subject view Author view Other groups

This archive was generated by hypermail 2b28 : Sat May 05 2001 - 07:33:00 EEST