Re: [ecasound] A few wah presets

New Message Reply Date view Thread view Subject view Author view Other groups

Subject: Re: [ecasound] A few wah presets
From: Kai Vehmanen (
Date: Wed Mar 21 2001 - 23:49:52 EET

On Fri, 16 Mar 2001, S. Massy wrote:

> I messed around for a while and found a couple of good autowah presets. It's
> basically just a lowpass filter moving up and down but it sounds quite nice.

Great! If it's ok to, I'll add these right away to the default
effect_preset's file.

> # I thought I'd add this preset to give those having a midi foot controller
> man_wah = -efl:0 -km:1,%low,%high,%cont,%chan

You know, you're quite good at this bug hunting thing.. ;) The above
example revealed a nasty MIDI-related bug in the preset code. At least
for now, MIDI ops are simply ignored in presets...

> Let me add, in the spirit of the pre-2.0 bug squashing party, that
> there is a bug in embeded parameters; they only work if their preset
> are in the main presets file (either in the system-wide or user
> directory), if they belong to a preset in a file you've specified with
> "-pf" the parameters default to zero no matter what value you tried to
> pass on the command line.

Are you sure? I just tested with few presets and seems to work. The
only time I had problems was when I had a connected chainsetup, engine was
stopped, and I tried to modify presets params with 'cop-set'. Because cs
is connected, ecasound will send the change requests to the engine, but
they won't have effect until engine is started...

 Audio software for Linux!

-- To unsubscribe send message 'unsubscribe' in the body of the message to <>.

New Message Reply Date view Thread view Subject view Author view Other groups

This archive was generated by hypermail 2b28 : Thu Mar 22 2001 - 00:01:03 EET