Re: [ecasound] delays using real-time w/redhat 7

New Message Reply Date view Thread view Subject view Author view Other groups

Subject: Re: [ecasound] delays using real-time w/redhat 7
From: Robert Jonsson (robert.jonsson@dataductus.se)
Date: Thu Jan 18 2001 - 08:16:24 EET


Robert Jonsson wrote:

  Hi,

  Greg Hamerly wrote:

> Hi,
>
> I'm having a problem with significant delays in ecasound audio
processing.
> I used it over the summer with redhat 6.2 and a self-compiled kernel and
> got good results. Now I have upgraded to redhat 7 with stock kernel
> (2.2.16), and running the command:
>
> > ecasound -r -b:16 -a:1 -i:/dev/dsp -o:/dev/dsp
>
> as root introduces a half-second delay between talking into the
microphone
> and hearing it come out.
>
> Every now and then (no rhyme or reason) the real-time audio kicks in and
> it works fine. But it is the exception, and I don't know why. Examining
> debug output (-d:255) from ecasound turns up nothing unusual.
>
> My setup is: redhat 7, pIII 500, 256 MB, soundblaster live value, stock
> redhat sound driver (module emu10k1). Ecasound was installed from the
> latest ecasound & ecasound-plugins RPMS (1.8.2r14-1).
>
> Has anyone else experienced this problem? Please let me know. Thanks,

  I haven't done any extensive testing but I think this is related to the
  emu10k1 driver. I got similar result when I tried to run some realtime
  tests a few months ago.
  A few times I got realtime results, but not very good, audible but short
  delay. But most oftenly the darn thing gave about half a millisecond
delay.

*::Argh, ofcourse I mean half a SECOND delay*....::

  Though my belief is that it's driver related, ecasound has probably
  something to do with it also. I tried the little realtime effect program
  ELE and the result is always instantaneous response.

  /Robert

--
To unsubscribe send message 'unsubscribe' in the body of the
message to <ecasound-list-request@wakkanet.fi>.


New Message Reply Date view Thread view Subject view Author view Other groups

This archive was generated by hypermail 2b28 : Thu Jan 18 2001 - 08:32:41 EET