Re: [ecasound] various

New Message Reply Date view Thread view Subject view Author view Other groups

Subject: Re: [ecasound] various
From: Kai Vehmanen (
Date: Thu Aug 24 2000 - 07:30:06 EEST

On Tue, 22 Aug 2000, Dave Phillips wrote:

> When entered at the prompt it works entirely as it should. However, when
> I open it in the Setup Session editor it looks like this:
> Note that '-kx -km:4,0,6,0,0' has disappeared from a:1. What's up with
> that ?

Uhm, I think you've just found a bug (-kx is a relatively new
addition). Will be fixed during 1.8.x development.

> Also, what is the correct syntax for the loop mechanism ? The man
> page states '-tl' but that produces an error. '-t:l' seems acceptable but
> does nothing.

You need to specify both -t:time_in_seconds and and -tl. Use -y to
specify when to start playback (and looping).

> Another question: MP3 playback is all wrong, but I suspect I'm the one
> who's all wrong. The files play at double speed (or more), with the
> resulting pitch shift. What am I missing there ?

This happens with mono mp3s. You must manually tell ecasound mp3's
channel count... for instance:

ecasound -f:16,1,44100 -i test.mp3 -f:16,2,44100 -o /dev/dsp

> Kai, ecasound is really impressive. I hope you're encouraged to continue
> maintaining it, I'm looking forward to how it might develop. Btw, I like
> the Qt interface in X, it's very handy. I've also compiled and run

This is good to hear. This summer has been a bit quiet
development-wise, but this situation will probably change in the fall.
All in all, things look good for ecasound...

 . ... [ audio software for linux ] /\ .
 . ... [ aivastus net radio ] /\ .
 . [ my armchair-tunes mp3/ra/wav ]

-- To unsubscribe send message 'unsubscribe' in the body of the message to <>.

New Message Reply Date view Thread view Subject view Author view Other groups

This archive was generated by hypermail 2b28 : Thu Aug 24 2000 - 18:56:23 EEST