Re: [ecasound] more problems

New Message Reply Date view Thread view Subject view Author view Other groups

Subject: Re: [ecasound] more problems
From: Kai Vehmanen (kaiv@wakkanet.fi)
Date: Fri Nov 19 1999 - 13:45:12 EET


On Thu, 18 Nov 1999, Jeremy Hall wrote:

> ecasound ('h' for help)> cop-status
[...]
> Chain "default":
> 1. Bandreject filter: [1] center-freq 1000.00, [2] width 1000.00
> 2. Bandpass filter: [1] center-freq 1000.00, [2] width 1000.00
[...]
> ecasound ('h' for help)> cop-remove 1

Ok, here you remove the first filter.

> ecasound ('h' for help)> c-remove 2

Here's an error. 'c-remove' removes all selected chains ('2'
is ignored). As your "default" chain is selected, it is removed.
And as there are no chains left, chainsetup is not valid anymore.

> (eca-controller) Warning! This operation requires that chainsetup is
> disconnected. Temporarily disconnecting...

Now when automatically reconnecting, it didn't check whether
chainsetup is still valid. Fixed this. Btw; If you try this with
'ecasound_debug', you get a failed assertation.

--
Kai Vehmanen <kaiv@wakkanet.fi> -------- CS, University of Turku, Finland
 . http://www.wakkanet.fi/ecasound/ - linux audio processing
 . http://www.wakkanet.fi/sculpscape/ - ambient-idm-rock-... mp3/ra/wav
 . http://www.wakkanet.fi/kerttulin_listat/ - music&movies (in Finnish)


New Message Reply Date view Thread view Subject view Author view Other groups

This archive was generated by hypermail 2a24 : Fri Nov 19 1999 - 17:53:14 EET